Sign in to follow this  
ppedro

[LINUX] [NVIDIA] Possible workaround for Graphical Glitches

Recommended Posts

Hello fellow The Long Darkies!

It seems most of us NVIDIA users are experiencing graphical glitching after the REDUX update. I have good news for you! I found these launch parameters (from Unity issue tracker) that fixed the glitching for me and allows me to continue surviving!

-force-glcore42 -force-clamped

Hope this helps! 

Remember to up vote the issue in the link I provided, so the problem gets enough attention and hopefully a quick and permanent fix. So that such workarounds wouldn't be needed in the future.

Antergos Linux 4.19.8-arch1-1-ARCH
I5-7600K, 16GB DDR4, GTX 1060 3G
nvidia 415.22, mesa 18.3.1-1

Edited by ppedro
  • Upvote 2
  • Like 1

Share this post


Link to post
Share on other sites

Ola and thanks for the tips, it worked for me

Debian 4.9.130-2
GTX 1050 (notebook, optimus), nvidia 384.130-1

 

But everything come with a cost ^^
Seems to me that the general quality of graphics are impacted (playing ultra), especially "smoke" effects (as in the breathing, or fire). And I experienced some freezing I never had.
I tested just a few minutes, so I'll try more and may edit this if needed.

Anyway the game is totally playable, thanks again, hoping also that Unity will revised their priority on that matter [edit: oh, ok, they reviewed the severity to more "critical" than just cosmetic as it was, good move](I had just 0 problem with this game pre-update).

Edited by LkP
  • Upvote 1

Share this post


Link to post
Share on other sites

Thats good to hear. :)

Yeah, I believe the -force-glcore42 means that Unity is launching with OpenGL 4.2, so newer graphics stuff are probably not working. Which might also explain why it seems some older NVIDIA cards are not experiencing the same problems (= they don't support higher versions of openGL anyway)

But I am just guessing, don't have much knowledge about different graphics APIs.

Share this post


Link to post
Share on other sites
4 hours ago, ppedro said:

I found these launch parameters

I will need a photo of you to put it in a great frame and burn incense and make some offerings to it every time I play TLD from now on. (I don't need a naked photo)

Made the game playable for me too. Yes the graphics are not as good as before, there is "cathodic TV noise" in the image, but hey that definitely better than seeing everything through everything.

Updated Ubuntu, GTX 750Ti, nvidia-driver-390

Share this post


Link to post
Share on other sites

This is working for me as well. Thank you very much.

...

Interesting. I was finding it very saturated, and I went and checked my brightness option. I had to turn it down a fair bit. I know it was well calibrated before, so it might be worth checking out for those folks that are finding their displays oversaturated with the blues and so on.

Share this post


Link to post
Share on other sites
Quote

Initialize engine version: 2018.3.7f1

😁

I've checked 15mn the last update, no problem without the work-around and back to "ultra" settings. Yes !

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this