Kael

WIll not load the game

3 posts in this topic

I've had this game for almost a year now I believe. It's always worked fine with no issues. However, recently (i'm assuming after an update) I decided to play it again after taking a bit of a break, and now the game refuses to get passed the initial loading screen. 

 

I get a "click any button" type text that pops up and I do. And it loads. And loads....and loads.....and oh hey it loads some more but never finishes loading anything. I've left it loading for almost 14 hours and it did absolutely nothing. I don't understand why as it was working perfectly fine just a few weeks before.

Share this post


Link to post
Share on other sites

Hello.

Try to search before opening a new topic.
 

This topic is almost on the top of the list talking about the same problem you're complaining.

Share this post


Link to post
Share on other sites

Hi @Kael, thanks for your post. The team is currently looking into reports of the game not launching correctly on some systems. 

If you haven't tried them yet, please try the steps for resolving common issues that are posted here. Let us know whether any of these steps help with your issue!

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now