niklanidja

Black screen and crashes my PC

92 posts in this topic

I did everything you guys wrote and still crash. Please help id love to play this game 

1

Share this post


Link to post
Share on other sites
3 hours ago, niklanidja said:

I did everything you guys wrote and still crash. Please help id love to play this game 

G'day and welcome to the forums!

Some information would help.. Can you please post the details of your PC.. CPU specs, how much RAM, what model graphics card it has, what version of Windows or Linux you're running, if you installed via Steam or GOG.. all that stuff. It's hard to know what might be wrong without the specifics.

1

Share this post


Link to post
Share on other sites
19 hours ago, JAFO said:

G'day and welcome to the forums!

Some information would help.. Can you please post the details of your PC.. CPU specs, how much RAM, what model graphics card it has, what version of Windows or Linux you're running, if you installed via Steam or GOG.. all that stuff. It's hard to know what might be wrong without the specifics.

24 gb  ram, gtx980 ti, i7 4770k windows 10 x64 GOG version 

1

Share this post


Link to post
Share on other sites

Posted (edited)

6 hours ago, niklanidja said:

24 gb  ram, gtx980 ti, i7 4770k windows 10 x64 GOG version 

Wow.. nice machine.. (well, apart from the Win10 bit, anyway ;) - sorry.. but being a computer tech I loathe Win10!).

Hmm.. TLD on GOG is something I've no experience with.. but I know they're currently a long way behind the current patches on Steam.. (v1.05 vs v1.12 IIRC)

While only patience can help with the patch issue, there might be a few things you can try while waiting..

Assuming the GOG version is basically identical to the Steam one, inside the TLD game installation folder, which should be located in "C:\Program Files (x86)\GalaxyClient\Games\", there should be a number of batch files to launch the game in various non-default modes. They are:

  • tld_borderless.bat
  • tld_borderless_dx9.bat
  • tld_borderless_dx11.bat
  • tld_dx9.bat
  • tld_dx11.bat
  • tld_multiscreen.bat

(By default Windows hides the ".bat" extension, so if the names match except for that ending bit, it's all good.) If you browse to the TLD folder* and shift-right-click (hold down the shift key while you right-click) in the white space area, one of the options should be "Open command window here". Select that and a command console will open. Type in "tld_borderless.bat" (without the quotes) or whichever one you want to try, hit the "Enter" key, and see if any of them can successfully launch the game for you.

Hopefully one of these options will work for you. Best of luck!
If they don't help, then it may be a graphics driver or overheating/overclocking issue.. but we'll get to that if the above doesn't work...

 

One way to open this folder is to open GOG Galaxy, go to the Library, move your mouse pointer over the TLD icon, and in the bottom-right of the game a drop-down arrow will appear. Click on this and one of the options will be "Settings". In the next window, next to the big green "Play" button will be another drop-down menu labelled "More". Click on it and move down the menu to the "Manage installation" option and one of the options that appears is "Show folder". Click on that and a window will open showing you the files inside the TLD installation folder.

Edited by JAFO
1

Share this post


Link to post
Share on other sites

I'll put my money on running it with:

tld_borderless_dx9.bat

That's running it borderless and with dx9. That one (in my opinion) has the best odds.....

0

Share this post


Link to post
Share on other sites
16 hours ago, JAFO said:

Wow.. nice machine.. (well, apart from the Win10 bit, anyway ;) - sorry.. but being a computer tech I loathe Win10!).

Hmm.. TLD on GOG is something I've no experience with.. but I know they're currently a long way behind the current patches on Steam.. (v1.05 vs v1.12 IIRC)

While only patience can help with the patch issue, there might be a few things you can try while waiting..

Assuming the GOG version is basically identical to the Steam one, inside the TLD game installation folder, which should be located in "C:\Program Files (x86)\GalaxyClient\Games\", there should be a number of batch files to launch the game in various non-default modes. They are:

  • tld_borderless.bat
  • tld_borderless_dx9.bat
  • tld_borderless_dx11.bat
  • tld_dx9.bat
  • tld_dx11.bat
  • tld_multiscreen.bat

(By default Windows hides the ".bat" extension, so if the names match except for that ending bit, it's all good.) If you browse to the TLD folder* and shift-right-click (hold down the shift key while you right-click) in the white space area, one of the options should be "Open command window here". Select that and a command console will open. Type in "tld_borderless.bat" (without the quotes) or whichever one you want to try, hit the "Enter" key, and see if any of them can successfully launch the game for you.

Hopefully one of these options will work for you. Best of luck!
If they don't help, then it may be a graphics driver or overheating/overclocking issue.. but we'll get to that if the above doesn't work...

 

One way to open this folder is to open GOG Galaxy, go to the Library, move your mouse pointer over the TLD icon, and in the bottom-right of the game a drop-down arrow will appear. Click on this and one of the options will be "Settings". In the next window, next to the big green "Play" button will be another drop-down menu labelled "More". Click on it and move down the menu to the "Manage installation" option and one of the options that appears is "Show folder". Click on that and a window will open showing you the files inside the TLD installation folder.

Already tried that, doesnt seem to work :(, thanks for trying to help buddy. I have even installed Windows 7 back and still the same xd

1

Share this post


Link to post
Share on other sites
14 hours ago, Thrasador said:

I'll put my money on running it with:

tld_borderless_dx9.bat

That's running it borderless and with dx9. That one (in my opinion) has the best odds.....

Already tried, no success :(, thanks anyhow! 

1

Share this post


Link to post
Share on other sites
45 minutes ago, niklanidja said:

Already tried, no success :(, thanks anyhow! 

Sorry m8!

0

Share this post


Link to post
Share on other sites
1 hour ago, Thrasador said:

Sorry m8!

Only thing that seems to work is windowed mode but not for more than 10-15 minutes, crashes afterwards. Too bad i really wanted to finish this game 

1

Share this post


Link to post
Share on other sites

Is the game crashing or is the display just going black? Is there an error code or anything? Is there a crash report? Do you get dumped to desktop? Do you have to reboot your computer? The more info you give detailing everything that is happening, the more likely it is that me, or Jafo, or someone else will figure this out....

I started reading about errors with that particular Nvidia card, but I need more info...

Have you updated to the latest Nvidia drivers?

0

Share this post


Link to post
Share on other sites
7 minutes ago, Thrasador said:

Is the game crashing or is the display just going black? Is there an error code or anything? Is there a crash report? Do you get dumped to desktop? Do you have to reboot your computer? The more info you give detailing everything that is happening, the more likely it is that me, or Jafo, or someone else will figure this out....

I started reading about errors with that particular Nvidia card, but I need more info...

Have you updated to the latest Nvidia drivers?

My whole PC freezes and screen turns dark,  sometimes i need to hard reset and sometime PC resets by itself. No error code, no crash report. And i do have the latest Nvidia drivers 

1

Share this post


Link to post
Share on other sites

I read some posts about that card going into standby mode....

I'm wondering if you go into power settings for Windows and change turn off monitor to "Never" and turn off hard drive to "never" if one or both of those will fix it.

I'm thinking it has to do with that specific graphics card. I have a very similar specs laptop but I have a Nvidia 980M and the game runs great for me....

You have a much better computer than what is required to run this game....

Is this happening with any other games or JUST The Long Dark?

0

Share this post


Link to post
Share on other sites
7 minutes ago, Thrasador said:

I read some posts about that card going into standby mode....

I'm wondering if you go into power settings for Windows and change turn off monitor to "Never" and turn off hard drive to "never" if one or both of those will fix it.

I'm thinking it has to do with that specific graphics card. I have a very similar specs laptop but I have a Nvidia 980M and the game runs great for me....

You have a much better computer than what is required to run this game....

Is this happening with any other games or JUST The Long Dark?

Already did the first part, thats what i usually do and yes, this is literally the only game that causes this 

1

Share this post


Link to post
Share on other sites

Did you build this PC yourself from parts you ordered? Or did you buy it already built?

0

Share this post


Link to post
Share on other sites

Ok, well most of the stuff I'm reading about that model card and "black screen crashes" has to do with any game or at least multiple games.

Since it is ONLY crashing with The Long Dark I'm wondering if you are forcing a graphics setting onto the game that it does not like.

Do you have all your Nvidia settings on the recommended settings? And do you have the settings that let you choose "application controlled" set to "application controlled."

And turn any silly new stuff like Nvidia's new "G-sync" off.....

0

Share this post


Link to post
Share on other sites

 Does NVIDIA G-SYNC work for all games?

A: NVIDIA G-SYNC works with all games. However, we have found some games that do not behave well and for those, we recommend that users take advantage of our control panel’s ability to disable G-SYNC per game. Games that NVIDIA discovers that have trouble with G-SYNC will be disabled by default in our driver.

0

Share this post


Link to post
Share on other sites
9 minutes ago, Thrasador said:

Did you build this PC yourself from parts you ordered? Or did you buy it already built?

Self built

1

Share this post


Link to post
Share on other sites
3 minutes ago, Thrasador said:

Ok, well most of the stuff I'm reading about that model card and "black screen crashes" has to do with any game or at least multiple games.

Since it is ONLY crashing with The Long Dark I'm wondering if you are forcing a graphics setting onto the game that it does not like.

Do you have all your Nvidia settings on the recommended settings? And do you have the settings that let you choose "application controlled" set to "application controlled."

And turn any silly new stuff like Nvidia's new "G-sync" off.....

I tried with all on low and ultra etc still the same, in nvidia control panel tried with default settings and with my settings still the same.
G sync i do not have since i dont own a g sync monitor 

1

Share this post


Link to post
Share on other sites

I asked if you built it because one of the issues with the card has to do with plugging the wrong power connectors into it....or switching them if there are others you aern't using.....but again if it was that, it would PROBABLY be affecting more games...

0

Share this post


Link to post
Share on other sites

Well even if you dont have a G-sync monitor they still have a setting for it in the NVIDIA control panel I think....I was just saying make sure you have that set to off....

I'm pretty much at a loss now if you tried all that stuff.....

I can't think of anything else to try....

Maybe when @JAFOwakes up, he'll have some other ideas....

He's on Australian time....he usually shows up after 9PM my time....which is Eastern...

0

Share this post


Link to post
Share on other sites
3 minutes ago, Thrasador said:

I asked if you built it because one of the issues with the card has to do with plugging the wrong power connectors into it....or switching them if there are others you aern't using.....but again if it was that, it would PROBABLY be affecting more games...

Yeah i get that, thats why i couldnt find a solution yet, its really weird 

1

Share this post


Link to post
Share on other sites
Just now, Thrasador said:

Well even if you dont have a G-sync monitor they still have a setting for it in the NVIDIA control panel I think....I was just saying make sure you have that set to off....

I'm pretty much at a loss now if you tried all that stuff.....

I can't think of anything else to try....

Maybe when @JAFOwakes up, he'll have some other ideas....

He's on Australian time....he usually shows up after 9PM my time....which is Eastern...

All good, thank you once again for trying to help me!

1

Share this post


Link to post
Share on other sites

Posted (edited)

Well, I'll keep thinking about it. It sounds like you are pretty smart too, so you should keep researching it. Jafo also likes solving problems and has an IT background....maybe if he reads everything we just talked about, he'll come up with some ideas too.....

Edited by Thrasador
0

Share this post


Link to post
Share on other sites

Posted (edited)

So this isn't over....yet....lol.

Jafo hates being beaten by a stupid box....

Edited by Thrasador
0

Share this post


Link to post
Share on other sites
3 minutes ago, Thrasador said:

Well, I'll keep thinking about it. It sounds like you are pretty smart too, so you should keep researching it. Jafo also likes solving problems and has sn IT background....maybe if he reads everything we just talked about, he'll come up with some ideas too.....

I hope so haha :D

1

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now