stratvox

Mouse cursor disappears under linux

22 posts in this topic

Once I enter a game, the mouse cursor is invisible when trying to navigate menus. Eventually, it seems to end up disabled; even blind moving the mouse around while waiting for the menu option to highlight stops working. It makes the game unplayable.

Ubuntu 16.04, all up to date drivers etc.

0

Share this post


Link to post
Share on other sites

I've run into the same issue. Ubuntu 16.04. Dell Precision 5520. Nvidia drivers.

The mouse is available when I launch the game, and I can navigate the menu until a new game begins. Once the new game begins, the mouse disappears. When I pull up the inventory, if I wiggle the mouse a lot, sometimes buttons will highlight. But, as stratvox says, after a while even that quits working.

Maybe there's a way to play without having a cursor, but I haven't figured it out yet.

0

Share this post


Link to post
Share on other sites

Same problem here, the mouse cursor is invisible when trying to navigate menus.

Ubuntu 16.04.
Nvidia drivers.
System is up to date.
Play on Steam.

0

Share this post


Link to post
Share on other sites

I believe i am experiencing the same issue. I am running steam on linux mint with nvidia drivers the game loads and runs fine until i need to enter an options or other sub menu at which point i can navigate the menu with the arrow keys, but even when the confirm button appears beside the back button in the lower left of the screen (after changing a setting in options) it remains greyed out.  There is no visible mouse cursor to move to the button and no other means with the arrow keys or tab or anything else to select the button. I have read elsewhere that selecting unlock the mouse cursor in options can resolve similar issues however while i can change the setting with my arrow keys i can not save the change as i can not hit the confirm button. I have attempted to navigate to the confirm button with the mouse in case the cursor is simply invisible but at no point is there any audible or visuall response that the cursor may have moved over the confirm button so i believe the cursor is not only invisible but non functioning also.

0

Share this post


Link to post
Share on other sites

Same here as the OP. Running Kubuntu 16.04 with the current stable proprietary NVIDIA driver.

It's my understanding that this issue affects at least some Debian users as well.

Tried the game on openSUSE. That was a disaster. Nothing but a black screen similar to the experience of some Fedora users.

0

Share this post


Link to post
Share on other sites

Posted (edited)

I figured it out. You need to set the mouse cursor to be not locked to the window, and the cursor works. When you launch the game, go into options while you still have the mouse cursor (before you go into an actual game, that is), set the mouse to be not locked to the window, and the cursor will work in the game.

Edited by stratvox
0

Share this post


Link to post
Share on other sites

I do not have the mouse cursor visible in the options menu to make that change. Does anyone know of a way to perhaps edit a settings file outside of the game to put the game in to mouse cursor "not locked" state,as a temporary fix?

0

Share this post


Link to post
Share on other sites

Hey, pinaclepixel, I found that you could only do it when you initially loaded the game, before loading a saved game or starting a new one.

0

Share this post


Link to post
Share on other sites

Are you saying i need a complete fresh install and not have previously tried to start a game?

I raised this as a bug

TLDP-2998

 

0

Share this post


Link to post
Share on other sites
1 hour ago, stratvox said:

I figured it out. You need to set the mouse cursor to be not locked to the window, and the cursor works. When you launch the game, go into options while you still have the mouse cursor (before you go into an actual game, that is), set the mouse to be not locked to the window, and the cursor will work in the game.

I attempted this yesterday. Unfortunately the cursor becomes disabled far to quickly on my system. I can make these selections in the menu using the WASD keys but I can't save the settings (no way to click "CONFIRM").

0

Share this post


Link to post
Share on other sites
On 04/08/2017 at 1:25 AM, stratvox said:

Hey, pinaclepixel, I found that you could only do it when you initially loaded the game, before loading a saved game or starting a new one.

Thanks for this pointer. after a couple of attempts i managed to hit confirm on the options screen in the brief initial second or 2 that the mouse is active. Until you posted that you had succeeded i had all but given up. the game really needs to default to mouse unlocked on all linux i suspect.

to anyone experiencing the same issue.

follow these steps.

open the game in steam.

once the game loads and you are presented with the disclaimer move your mouse cursor but don't click a mouse button.

hit space bar to progress to the cut scene (for me this is just an period of black screen) if i recall correctly the hunting lodge with the smoke coming from the chimney scene is displayed next.

pressing a keyboard key should take you to the game menu.

At this point use your arrow keys to select the options menu and hit enter to select.

In the next display, using the arrow keys, navigate down the list until unlock mouse is highlighted and hit enter. Then quickly gesture with your mouse to move the cursor from roughly center screen down to the now present Confirm button. Although the cursor is never visible it is active (at least for me and stratvox) for a couple of seconds. If you pass over the confirm button in this time it will highlight. Click left mouse when confirm is highlighted and the cursor magically appears and the rest of the game is yours to enjoy. Except for the conversation pieces in your interaction with grey mother, which for me at least mysteriously have no audio and no charachter synced lip movement only the changing response button to further the conversation or ask a different question.

 

I hope this is helpful. it took me several attempts. At each attempt you must have restarted the game not just re entered the option menu.

be persistant, the first time i got a glimmer of hope was when moving the mouse without a visible cursor actually highlighted the confirm button, however i was too slow centering the invisible cursor back on the confirm button to select it before all mouse activity was lost. a further 3 attempts and i finally got it.

0

Share this post


Link to post
Share on other sites
On 8/4/2017 at 9:09 PM, pinaclepixel said:

...once the game loads and you are presented with the disclaimer move your mouse cursor but don't click a mouse button...Then quickly gesture with your mouse to move the cursor from roughly center screen down to the now present Confirm button...I hope this is helpful...

Yeah. Thanks. Got it 1st attempt simply by not touching the mouse until ready to 'CONFIRM' my changes.

I had already given up on the game but now I'll give it another try...Thanks.

0

Share this post


Link to post
Share on other sites
8 hours ago, Meat said:

Yeah. Thanks. Got it 1st attempt simply by not touching the mouse until ready to 'CONFIRM' my changes.

I had already given up on the game but now I'll give it another try...Thanks.

Yeah, I hear you. I didn't play at all for the first few weeks I had the game because I simply couldn't get the mouse to go. Eventually I got to the workaround. Happily, it turned out the game is worth that angst. Hopefully Hinterland can get the outstanding issues fixed up soon so the angst can go away.

0

Share this post


Link to post
Share on other sites

Agreed Stratvox. Well worth fiddling to get it going, loving it so far are you also having an issue with the interactive dialogue audio and some cut scenes not displaying? if so have you discovered any work arounds?

 

0

Share this post


Link to post
Share on other sites

Found a more simple workaround:

  1. Start the game
  2. Press some key to reach the intro
  3. Stay calmed, although your mouse is stolen
  4. kill the process
  5. start the game again
  6. now they allow you to kill the intro, since they have created their config folder in your home directory. When you reach the "press a key" screen, press ESC qickly after another. This skips the intro quickly, before they eat your mouse
  7. You should reach the main menu. Disable "lock mouse to screen" in the settings menu.
  8. Open a thread here. Name it "How can such dumb guys who prevent their buyers from changing their config files to workaround a game breaking bug make such a good game? Any Ideas?"
  9. Play this amazing game
0

Share this post


Link to post
Share on other sites
On 8/6/2017 at 6:51 PM, stratvox said:

Yeah, I hear you. I didn't play at all for the first few weeks I had the game because I simply couldn't get the mouse to go. Eventually I got to the workaround. Happily, it turned out the game is worth that angst. Hopefully Hinterland can get the outstanding issues fixed up soon so the angst can go away.

Well, after about 100 hours of gameplay over the past 3 weeks, I guess I might agree that "the game is worth that angst." Still some Linux-only issues remaining in the game but nothing that makes it unplayable now...at least in Sandbox mode. I haven't attempted Story yet and I have little interest in doing so at this time. Really, REALLY enjoying Survival.

0

Share this post


Link to post
Share on other sites

This does not work for me. I get stuck at the screen where you have to set the brightness. I do not even reach the intro. I can't click the "Okay" (Confirm) Button, because i have no cursor. :( Maybe it works if i create the config-folder for my own? What's the name of the config folder? Can anyone tell me? Using Debian 9.

0

Share this post


Link to post
Share on other sites

I have the same problem here, I've deleted the config folder, reinstalled the game, still can't get a mouse cursor, so can't click ok.

I've been playing the game successfully for well over a year, until I decided to lock the mouse to the screen.

0

Share this post


Link to post
Share on other sites
On 8/27/2017 at 4:25 PM, weyoun said:

...I can't click the "Okay" (Confirm) Button, because i have no cursor. 

7 hours ago, Jeff Carr said:

I... still can't get a mouse cursor, so can't click ok.

 

You won't get a mouse cursor until you confirm your selection. However, you can still highlight and click "CONFIRM" if you:

(a) don't click anything until you're ready to confirm your selection,

(b) don't move the mouse until you're ready to "Confirm" your selection, and

(c) you're fast

The trick is to start the game, then get to the menus without clicking anything. Use the navigation keys to navigate the menu and select "Unlock Mouse"

At this point you still won't have a visible mouse cursor but you should be able to highlight (and click) the "CONFIRM" button if you're fast enough. Just remember, once you start moving the mouse to hunt for the "CONFIRM" button, you only have a second or two before the mouse stops working completely. If this happens, you'll have to start the process over.

You should be able to highlight and click that Confirm button eventually. It's difficult without being able to see the cursor but it's not impossible.

Edited by Meat
0

Share this post


Link to post
Share on other sites
On 9/4/2017 at 3:06 AM, Meat said:

You won't get a mouse cursor until you confirm your selection. However, you can still highlight and click "CONFIRM" if you: ...

I'm glad that works for you, but it doesn't work for me, I've tried it a number of times.  I need a way to click confirm without a mouse, be able to edit the config files with a simple text editor, a command line switch to turn that off, or just about anything else.  My mouse is locked immediately no matter what I've done.

0

Share this post


Link to post
Share on other sites
On 9/9/2017 at 2:39 PM, Jeff Carr said:

I need a way to click confirm without a mouse, be able to edit the config files with a simple text editor...

That's the first thing that I looked for but no luck.

Considering that it's such a serious glitch that makes the game totally unplayable for so many purchasers of the game and the fact that it should be such an easy fix for them, I'm saddened that the devs have chosen to ignore it for so long and then decided that it was time for a month-long vacation.

Hopefully they'll get it fixed by the end of the year.

0

Share this post


Link to post
Share on other sites

I'm having this problem as well, and can't quite seem to get any of the workarounds above to work.  I'm running Ubuntu 16.04 LTS, on a hardware configuration that I have previously run TLD on using Windows 10, so I know it's it isn't the hardware itself.  The fact that there's no way to even select "confirm" using the keyboard is absolutely maddening.

0

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now